By
updated 5/4/2012 5:50:41 PM ET 2012-05-04T21:50:41

Stop what you're doing and update your Adobe Flash software.

That's the message the software giant put out today (May 4) in a security advisory  warning users of a critical Flash Player flaw currently being exploited in targeted attacks.

The "object confusion vulnerability," as Adobe calls it, "could cause the application to crash and potentially allow an attacker to take control of the affected system." Attackers, Adobe said, have exploited the critical security glitch by tricking victims into clicking on a rigged, malicious file in an email.

The update, to Flash Player version 11.2.202.235, fixes the flaw in Windows, Mac, Linux and Android operating systems. It is available at Adobe's website.

© 2012 SecurityNewsDaily. All rights reserved

Discuss:

Discussion comments

,

Most active discussions

  1. votes comments
  2. votes comments
  3. votes comments
  4. votes comments